Connecting to Serial port Issues

So my first USB-Serial adapter arrived from ebay - I ordered a couple of different ones, with hopefully different chipsets - this first one is a CH340

However it has not worked - I just get 'Control Lab not Connected"

I think it worked the first time, but while exploring the interface, I changed from Control Lab 1, to Control Lab 4, and got the immediate disconnect + quit of the program

Where does the program store it’s config? and is there anything else worth checking out, before giving up on this adapter, and waiting for the next?


OK… so my 2nd USB-Serial cable has worked fine.

Looking forward to seeing what I can do with it!

1 Like

Rohan, I am glad the second USB-Serial Cable worked for you! I have found that making sure the USB-Serial cable has the Prolific PL2303HXD Chipset works the best across platforms.

Here are a few I have tested:

Cable Matters USB to Serial Adapter Cable (USB to RS232, USB to DB9) 3 Feet
Plugable USB to Serial Adapter
Ableconn USB232DB9 USB to RS-232 DB9 Serial Adapter Cable

This last one I am not sure if it has the Prolific Chipset but does have great driver support across PC and especially Mac - but is way more expensive.

Tripp Lite Keyspan High-Speed USB to Serial Adapter, PC & Mac (USA-19HS)